Vilma
-8 °C
3 °C

Súlyos biztonsági réssel kezdett a Netscape 8

2005.05.23. 13:46
Túl korán örültek azok, akik az elsők között kezdték el használni a Netscape új böngészőjét. Az AOL fejlesztői ugyanis a kibocsátás után néhány órával döbbentek rá, hogy nem használták fel a Mozilla projekt legutóbbi javításait.
Klasszikus hibával engedték útjára készítői a Netscape várva várt új verzióját. Az AOL fejlesztői a telepítőkészlet kiadása után néhány órával döbbentek rá, hogy a többek közt a Mozilla Firefoxon alapuló 8-as verziójú Netscape olyan biztonsági rést hordoz, amelyet a nyílt forráskódú böngészőben már kijavítottak.

A probléma onnan ered, hogy a Netscape-t a fejlesztők a Firefox 1.0.3-as változatának alapjain építették. A Firefoxról később kiderült, hogy néhány ponton javításra szorul, de ezt a Netscape-projektben már nem vették figyelembe.

Ekézték a Firefoxot

A szükséges frissítések telepítése után a Netscape felhasználói is valószínűleg elfelejthetik a gikszert. Addig viszont fokozott elővigyázatosságra van szükség, hiszen a Firefox 1.0.4-ben kijavított hibák közül a legsúlyosabbat kihasználva manipulált oldalak ártalmas kódot csempészhetnek a számítógépre.

Számos Firefox-fejlesztő nem titkolt kárörömmel figyeli az AOL-nál zajló fejleményeket. A Netscape ugyanis a weboldala felkeresésekor a Firefox-felhasználókat "elavult" programjuk miatt új böngésző beszerzésére biztatja.

Két helyről a bajt

A Netscape kritikusai már egy ideje hangot adtak aggodalmuknak, hogy két böngésző, a Mozilla Firefox és az Internet Explorer grafikus motorjának integrálásával a felhasználók két helyről származó biztonsági hibák miatt aggódhatnak.

Időközben az AOL javította a tévedést, és kiadta a Netscape aktuális, 8.0.1-es változatát, amely a Firefox 1.0.4-en alapul. Azok a felhasználók, akiknek sikerült eredeti Netscape 8-hoz jutniuk, a hiba súlyossága miatt jól teszik, ha sürgősen 8.0.1-re frissítenek.